标签类目:LNMP

LNMP一键安装包 V1.5 正式版发布

2018-06-05 | 浏览人数: 623次 | 分类:服务器环境搭建 | 1条评论 | 查看评论 发表评论

LNMP 1.5正式版一如既往的6.1发布了,本版主要新增加PHP7.2支持、增加Maria DB 10.2、增加无人值守安装、增加多核编译安装、替换问题较多的certbot使用acme.sh不需要过多的依赖生成SSL更丝滑、支持生成泛域名SSL证书、lnmp管理脚本增加pathinfo选项、lnmp.conf中增加PHP模块fileinfo安装选项和Nginx lua模块安装选项、增加一些常用伪静态、Apache 2.4支持到http2、Nginx默认支持stream等功能,增加了一些特殊环境下的适应patch,优化了诸多细节等具体可以查看lnmp更新记录

LNMP一键安装包是一个用Linux Shell编写的可以为CentOS/RHEL/Fedora/Debian/Ubuntu/Raspbian/Deepin/Aliyun/Amazon/Mint Linux VPS或独立主机安装LNMP(Nginx/MySQL/PHP)、LNMPA(Nginx/MySQL/PHP/Apache)、LAMP(Apache/MySQL/PHP)生产环境的Shell程序。支持自定义Nginx、PHP编译参数及网站和数据库目录、支持生成LetseEcrypt证书、LNMP模式支持多PHP版本、支持单独安装Nginx/MySQL/MariaDB/Pureftpd服务器,同时提供一些实用的辅助工具如:虚拟主机管理、FTP用户管理、Nginx、MySQL/MariaDB、PHP的升级、常用缓存组件Redis/Xcache等的安装、重置MySQL root密码、502自动重启、日志切割、SSH防护DenyHosts/Fail2Ban、备份等许多实用脚本。

Tags:

LNMP一键安装包 V1.5 测试版发布

2018-01-14 | 浏览人数: 1,357次 | 分类:服务器环境搭建 | 查看评论 发表评论

军哥,最新的LNMP 1.5版本发布了,我们来一起看下最新版的特性吧。

LNMP 1.5测试版,主要新增加PHP7.2支持、增加Maria DB 10.2、替换问题较多的certbot使用acme.sh不需要过多的依赖生成SSL更丝滑、lnmp管理脚本增加pathinfo选项、lnmp.conf中增加PHP模块fileinfo选项和Nginx lua模块选项、增加一些常用伪静态、Apache 2.4支持到http2、Nginx默认支持stream等功能。

LNMP一键安装包是一个用Linux Shell编写的可以为CentOS/RHEL/Fedora/Debian/Ubuntu/Raspbian/Deepin/Aliyun/Amazon/Mint Linux VPS或独立主机安装LNMP(Nginx/MySQL/PHP)、LNMPA(Nginx/MySQL/PHP/Apache)、LAMP(Apache/MySQL/PHP)生产环境的Shell程序。支持自定义Nginx、PHP编译参数及网站和数据库目录、支持生成LetseEcrypt证书、LNMP模式支持多PHP版本、支持单独安装Nginx/MySQL/MariaDB/Pureftpd服务器,同时提供一些实用的辅助工具如:虚拟主机管理、FTP用户管理、Nginx、MySQL/MariaDB、PHP的升级、常用缓存组件Redis/Xcache等的安装、重置MySQL root密码、502自动重启、日志切割、SSH防护DenyHosts/Fail2Ban、备份等许多实用脚本。

Tags:

2017年6月1日 LNMP发布1.4正式版

2017-06-01 | 浏览人数: 2,477次 | 分类:VPS管理维护 | 查看评论 发表评论

军哥老惯例,2017年6月1日发布LNMP 1.4正式版
附上升级教程:https://lnmp.org/faq/upgrade1-4.html
升级管理脚本:wget -c http://soft.vpser.net/lnmp1.4.tar.gz && tar zxf lnmp1.4.tar.gz && cd lnmp1.4 && upgrade1.x-1.4.sh

Tags:

LNMP一键安装包 V1.3 正式版发布

2016-06-03 | 浏览人数: 2,515次 | 分类:VPS控制面板 | 查看评论 发表评论

LNMP一键安装包 V1.3正式发布,增加PHP7、mysql 5.7支持、nginx http2支持、增加lnmp.conf配置文件开源自定义数据库目录、自定义参数,优化安装脚本增加安装成功率等等。

LNMP一键安装包是一个用Linux Shell编写的可以为CentOS/RadHat/Fedora、Debian/Ubuntu/Raspbian/Deepin Linux VPS或独立主机安装LNMP(Nginx/MySQL/PHP)、LNMPA(Nginx/MySQL/PHP/Apache)、LAMP(Apache/MySQL/PHP)生产环境的Shell程序。同时提供一些实用的辅助工具如:虚拟主机管理、FTP用户管理、Nginx、MySQL/MariaDB、PHP的升级、常用缓存组件的安装、重置MySQL root密码、502自动重启、日志切割、SSH防护DenyHosts/Fail2Ban、备份等许多实用脚本。

Tags:

LNMP一键安装包 V1.1 发布

2014-06-07 | 浏览人数: 2,531次 | 分类:服务器环境搭建 | 查看评论 发表评论

LNMP一键安装包是一个用Linux Shell编写的可以为CentOS/RadHat、Debian/Ubuntu VPS(VDS)或独立主机安装LNMP(Nginx、MySQL/MariaDB、PHP、phpMyAdmin)生产环境的Shell程序。同时提供一些实用的辅助脚本如:可以帮助完成Nginx、MySQL/MariaDB、PHP的升级、常用缓存组件的安装、重置MySQL root密码、502自动重启、日志切割等许多实用脚本。

Tags:

LNMP 修复OpenSSL漏洞

2014-04-15 | 浏览人数: 3,706次 | 分类:VPS安全 | 查看评论 发表评论

VPS安装LNMP的同学比较多,那怎么知道自己有没有OpenSSL的漏洞呢?

博主去和军哥了解过,军哥表示只要没开ssl就不受漏洞影响。如果大家不放心的话,可以通过下面的网站在线监测。

https://filippo.io/Heartbleed/

如果有漏洞的话会显示:

www.你的域名.com IS VULNERABLE.

LNMP一键安装包的Nginx 502 Bad Gateway错误可能原因及解决方法

2013-11-25 | 浏览人数: 2,973次 | 分类:VPS管理维护 | 查看评论 发表评论

今天一个安装lnmp的VPS频繁出现502 Bad Gateway错误,然后再军哥的网站找到一个解决办法的文章,转载过来方便后来人。

第一种原因:安装lnmp一键安装包时php没安装成功而出现502 Bad Gateway,从0.9开始只要安装成功或失败都就会有提示。没安装成功一般原因是在安装php前,脚本中某些lib包可能没有安装上,造成php没有编译安装成功。可以看一下是否存在/usr/local/php/sbin/php-fpm ,如果没有肯定没安装成功
解决方法:
可以尝试根据lnmp一键安装包中的脚本手动安装一下,看看是什么错误导致的,在网上搜索一下,或者把错误信息发上来。如果实在不会提供按http://lnmp.org/install.html这个安装时的lnmp.log日志文件(可以用winscp登陆下载lnmp.log,压缩并上传到本论坛),没有错误信息我们没法说什么原因。本方法只限于lnmp没安装成功,只要lnmp安装成功了这一项就没可能。

LNMP一键安装包 V1.0 发布

2013-06-01 | 浏览人数: 4,190次 | 分类:服务器环境搭建 | 2条评论 | 查看评论 发表评论

军哥的LNMP如期更新了,下面是全文转载,需要更新的同学抓紧是更新哈。

LNMP一键安装包是一个用Linux Shell编写的可以为CentOS/RadHat、Debian/Ubuntu VPS(VDS)或独立主机安装LNMP(Nginx、MySQL、PHP、phpMyAdmin)生产环境的Shell程序。

Tags:

LNMP/Nginx面板 – AMH3.1 发布

2013-03-09 | 浏览人数: 5,850次 | 分类:VPS控制面板 | 查看评论 发表评论

AMH3.1 版本更新日志:

1、面板module模块扩展增加在线下载模块与删除模块。
2、更正FTP用户高级选项限制存在的问题、与改进面板FTP管理。
3、FTP被动模式支持。(用户反馈: zgzm)
4、Nginx错误日志关闭问题。 (用户反馈: 老虎会游泳)
5、精确硬盘容量取值与个别IP获取不准确问题。 (用户反馈: 小白很白、shylocker110)
6、面板登录验证码大写问题。
7、取消AMH3.0版本Nginx默认安装第三方模块,以保持扩展AMH模块独立性。

Tags:

LNMP下Nginx 中文文件名或目录404无法访问的解决方法

2013-01-25 | 浏览人数: 4,359次 | 分类:VPS管理维护 | 2条评论 | 查看评论 发表评论

这个问题已经说过很多次,不过貌似很多人还是会遇到中文乱码的问题,Apache可以使用mod_encoding支持中文目录和文件,LNMP下Nginx其实不需要安装额外的组件即可支持中文文件名或中文目录,下面说一下常见的CentOS、Debian、Ubuntu Linux发行版下的设置方法和可能会遇到的问题:

设置前可以执行:locale 看一下,如果显示是en_US.UTF-8,即是正常,不用按下面的步骤设置。如果显示其他编码需要按如下步骤设置。

CentOS:

编辑/etc/sysconfig/i18n 文件,内容修改为:
LANG=”en_US.UTF-8″
SYSFONT=”latarcyrheb-sun16″

保存,重启系统。

LNMP下防跨站、跨目录安全设置,仅支持PHP 5.3.3以上版本

2012-10-06 | 浏览人数: 3,826次 | 分类:VPS安全 | 查看评论 发表评论

LNMP一键安装包下存在跨站和跨目录的问题,跨站和跨目录影响同服务器/VPS上的其他网站,最近看PHP 5.3,在5.3.3以上已经增加了HOST配置,可以起到防跨站、跨目录的问题。

如果你是PHP 5.3.3以上的版本,可以修改/usr/local/php/etc/php.ini在末尾里加入:

[HOST=www.abc.com]
open_basedir=/home/wwwroot/www.abc.com/:/tmp/
[PATH=/home/wwwroot/www.abc.com]
open_basedir=/home/wwwroot/www.abc.com/:/tmp/

LNMP一键安装包 0.9发布

2012-04-24 | 浏览人数: 3,775次 | 分类:服务器环境搭建 | 2条评论 | 查看评论 发表评论

来之军哥LNMP最新版本:

LNMP一键安装包是一个用Linux Shell编写的可以为CentOS/RadHat、Debian/Ubuntu VPS(VDS)或独立主机安装LNMP(Nginx、MySQL、PHP、phpMyAdmin)生产环境的Shell程序。

LNMPA是在LNMP的基础上产生的新的扩展,目前LNMP一键安装包的用户可以直接升级到LNMPA(Nginx、MySQL、PHP、 Apache),由Nginx作为前端处理静态页面、js、图片等,Apache作为后端处理PHP,解决高并发时php-cgi的502问题,提高服务 器处理动态内容的能力及稳定性。

nginx: [warn] the “log_format” directive may be used only on “http” level 解决方法

2012-02-19 | 浏览人数: 3,900次 | 分类:VPS管理维护 | 查看评论 发表评论

来自军哥博客的LNMP的最新解决方法,现在转载如下:

一直不提倡使用最新的版本,不过也真因为有部分爱折腾的才会不断的发现问题。目前Nginx的稳定版本是1.0.12,Nginx升级到1.1.1*版本后,会出现nginx: [warn] the “log_format” directive may be used only on “http” level in /usr/local/nginx/conf/nginx.conf:84的警告。

LNMP PHP 5.2.* Hash漏洞修复脚本

2012-01-11 | 浏览人数: 3,396次 | 分类:VPS安全 | 查看评论 发表评论

自从PHP Hash漏洞被爆后,很多同学问deepvps怎么修补。今天看到军哥的博客发布了修补方法,转载如下,方便大家修补哦。

本修复脚本主要针对PHP 5.2.* 版本,使用修复脚本,会将PHP升级到5.2.17,不需要放在PHP源码目录,任意目录即可。

执行如下命令:wget http://soft.vpser.net/lnmp/ext/fix_php5.2_hash.sh;sh fix_php5.2_hash.sh

按提示回车确认就会自动开始安装。

LNMP一键安装包 0.8发布

2011-12-14 | 浏览人数: 3,599次 | 分类:服务器环境搭建 | 查看评论 发表评论

LNMP一键安装包是一个用Linux Shell编写的可以为CentOS/RadHat、Debian/Ubuntu VPS(VDS)或独立主机安装LNMP(Nginx、MySQL、PHP、phpMyAdmin)生产环境的Shell程序。

LNMPA是在LNMP的基础上产生的新的扩展,目前LNMP一键安装包的用户可以直接升级到LNMPA(Nginx、MySQL、PHP、 Apache),由Nginx作为前端处理静态页面、js、图片等,Apache作为后端处理PHP,解决高并发时php-cgi的502问题,提高服务 器处理动态内容的能力及稳定性。

LNMP一键安装包 0.8 & LNMPA已经在VPSYOU(感谢提供测试VPS)、DiaHosting(感谢提供测试VPS)、PhotonVPS(感谢提供测试VPS)、vpszzMyHost123瑞豪开源VPSBurstNetYardVPSDirectSpaceThrustVPSBuyVM123Systems等多家美国VPS的CentOS、Debian、Ubuntu的32位和64位系统上测试通过(CentOS/Debian 均为5.0以上版本,Ubuntu为9.04以上版本),个别128MB小内存CentOS 64位模板存在问题,小内存请尽量选择32位。

页码: 1 2 后一页